I'm new to the dVSwitch so bear with me.
I'm thinking of migrating (eventually) from standard vSwitch on 3 ESX hosts to dvSwitch. Each vSwitch has it's own uplink to Cisco switches and those ports are access ports on their proper vlans.
What I'm THINKING I can do (please correct me if I'm wrong).
Create one dvSwitch
Attach 4 NICs per ESX host as uplinks.
On dvSwitch-DVUplinks specify VLAN Trunk: 0-4094
Create a dvPortGroup-VLAN1-LAN - Specify VLAN 1 under policies
Create a dvPortGroup-VLAN10-SAN - Specify VLAN 10 under policies
Create a dvPortGroup-VLAN20-DMZ - Specify VLAN 20 under policies.
Now the 4 physical nics from each host would be connected to 4 ports on a Cisco 3750. The switch configuration would be a Port-Channel defined for each ESX host.
interface Port-channel21
description ESX1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Gi1/0/1
description ESX1 vmnic1
switchport trunk encapsulation dot1q
channel-group 21 mode on
interface Gi1/0/2
description ESX1 vmnic2
switchport trunk encapsulation dot1q
channel-group 21 mode on
interface Gi1/0/3
description ESX1 vmnic3
switchport trunk encapsulation dot1q
channel-group 21 mode on
interface Gi1/0/4
description ESX1 vmnic4
switchport trunk encapsulation dot1q
channel-group 21 mode on
This would be a 4gbps trunk. Now if there are virtual machines I want in my DMZ, I place them in dvPortGroup-VLAN20-DMZ.
For vmware esx hosts to access the shared storage, I would place the storage console in dvPortGroup-VLAN10-SAN.
For virtual machines I want on the regular LAN I would place them in dvPortGroup-VLAN1-LAN.
Now all of our ports on switches with switchport access vlan 20 would be able to talk to any virtual machine in the portgroup specified in vlan 20, while any ports not specified would be able to talk to vm's on vlan1, but no traffic would interfere with each other... it would follow simple, straightforward vlan rules correct?
THANK YOU for clarifying this. I've never setup a dvSwitch and port-groups before. I'm hoping in the end since there are 8 vmnics per server that I put 4 on one switch and 4 on another switch for redundancy.